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제품 개발 프로세스
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• Altium 프로젝트 작업 과정



라이브러리 기본 설명

3

명칭 사용 처 파일명 용어

회로도 *.SchLib Symbol

PCB *.PcbLib Footprint

통합 라이브러리

(*.LibPkg)

회로도 라이브러리
(*.SchLib)

PCB 라이브러리

(*.PcbLib)

링크

통합 라이브러리

(*.IntLib)

Compile



라이브러리 관리 비교
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• Single Library • Integrated Library

[프로젝트 1]

회로도 & PCB

-10개 부품사용

내 회사 라이브러리
(수 천개)

[프로젝트 2]

회로도 & PCB

-10개 부품사용

내 회사 라이브러리
(수 천개)

용량 비교

프로젝트 1 100 MB

프로젝트 2 100 MB

[프로젝트 1]

회로도 & PCB

-10개 부품사용

내 회사 라이브러리
(수 천개)

[프로젝트 2]

회로도 & PCB

-10개 부품사용

용량 비교

프로젝트 1 10 MB

프로젝트 2 10 MB





라이선스 인증 및 프로그램 UI
1. 라이선스 인증

2. 확장시스템 설치 및 최신버전 업데이트

3. 사용자 인터페이스 소개



라이선스 인증
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확장시스템 설치 및 최신버전 업데이트

• Extension & Updates 에서 확장팩 설치 및 최신버전 업데이트를 지원한다.
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사용자 인터페이스
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명령 상태
패널

숨긴 패널 탭

메인 메뉴

작업영역

컴파일된 문서 탭

시스템 환경설정

알림

사용자정보

상태표시줄

고정 패널

Active Bar





환경설정
1. System 

2. Data Management

3. Schematic

4. PCB Editor



환경설정 : System

• System – General

• 현지화 : 언어설정을 위해 아래와 같이 설정한다.
• ▣ 현지화 리소스 사용

• ▣ 대화상자 현지화

• □ 메뉴 현지화

• 언어 설정 → 확인 → 프로그램 종료

→ 프로그램 재시작
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환경설정 : System
• System – View

• UI Theme

• Current

• Altium Dark Gray

• Altium Light Gray

• UI 설정 → 확인 → 프로그램 종료

→ 프로그램 재 시작
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환경설정 : System

• System – Navigation
• 회로도 컴파일 메시지 등

내용을 추적하여 부품을

표시할 때 확대 정도에

대한 설정
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환경설정 : System

• System – Design Insight

• 설계 정보
• 문서 정보 활성화

• 프로젝트 정보 활성화

• 연결 정보 활성화

• 공급망 정보 활성화

• 하이퍼링크 정보 활성화

• 마우스 부유 지연 속도 설정

• 연결 정보 옵션
• Document Tree

• Document Preview

• Object Hints

• Hyperlink
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환경설정 : System

• System – Default Locations
• Altium에서 제공되는 예제, 라이브러리, OutputJob, 템플릿의 기본 경로는 ..\공용문서\Altium\AD19로 등록

되어 있으며, System- Default Locations에서 기본 경로 변경 가능

• 기본 위치
• 문서 위치 : C:\Users\Public\Documents\Altium

• 라이브러리 위치 : C:\Users\Public\Documents\Altium\AD19\Library\

• OutputJob Path : C:\Users\Public\Documents\Altium\AD19\OutputJobs
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환경설정
1. System 

2. Data Management

3. Schematic

4. PCB Editor



환경설정 : Data Management

• Data Management – Backup
• 파일 백업을 위해 자동으로 저장할 시간, 파일 수, 경로 설정.

• 자동 저장
• 자동 저장 간격: ____분

• 자동 저장 백업 파일 수:____ (최대9개)

• 경로 : C:\Users\PC\AppData\Roaming\Altium\Altium Designer {------------------------}\\Recovery
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환경설정 : Data Management

• Data Management – File-based Libraries
• 자주 사용하는 통합 부품 라이브러리 등록을 위한 라이브러리 경로 지정
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환경설정 : Data Management

• Data Management – Parts Providers
• 부품 검색에서 제조 국가 및 제조사 옵션 선택으로 공급자 검색 설정
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환경설정
1. System 

2. Data Management

3. Schematic

4. PCB Editor



환경설정 : Schematic

• Schematic – General
• Units (단위)

• Mils, Millimeters

• 옵션
• 연결점 변환

• 배선 건넘 기호

• 포트 교차 참조
• 도면 모양

• - None -

• Name

• Number

• 위치 모양
• - None -

• Zone

• Location X,Y
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환경설정 : Schematic

• Schematic – Graphical Editing

• 옵션
• ▣ 반전 부호 ‘\’

• 자동 이동 옵션
• ▣ Enable Auto Pan

• 커서
• 커서 형식

• Large Cursor 90

• Small Cursor 90

• Small Cursor 45

• Tiny Cursor 45
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환경설정 : Schematic

• Schematic – Grid

• 격자 옵션
• Grid

• Line Grid (선)

• Dot Grid (점)

• 격자 색상

• 격자 사전 설정
• 격자 스냅

• Snap Distance

• 격자 표시
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환경설정 : Schematic

• Schematic – Break Wire
• 회로도 배선 연결을 잘라낼 때 사용

• 잘라낸 길이
• 세그먼트로 물기

• 다중 격자 크기 물기

• 고정 길이
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환경설정 : Schematic

• Schematic – Default
• 회로도에 사용하는 모든 객체의 초기 셋팅
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환경설정
1. System 

2. Data Management

3. Schematic

4. PCB Editor



환경설정 : PCB Editor

• PCB Editor – General (권장 설정)
• 기타

• 회전 각도 90.00

• 커서 형식 : Large 90

• Polygon Rebuild

• ▣ Repour Polygons After Modification

• ▣ Repour all dependent polygons after editing
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환경설정 : PCB Editor

• PCB Editor – Interactive Routing
• PCB의 패턴 작업 시 각종 옵션 기능을 설정하는 곳으로 배선에 관련되어 설정을 할 수 있다.

• 자주 사용하는 능동 배선의 폭의 리스트를 등록할 수 있으며, 배선중 [단축키 Shift + W]명령을 사용하면 배선

중 패턴 폭을 변경할 수 있다.

• 자주 사용하는 능동 배선의 폭의 리스트를 등록할 수 있으며, 배선중 [단축키 Shift + V]명령을 사용하면 배선

중 패턴 폭을 변경할 수 있다.
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환경설정 : PCB Editor

• PCB Editor - Default
• PCB에서 사용하는 객체 속성의 기본값들을 설정 할 수 있다.
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환경설정 : PCB Editor

• PCB Editor – Layer Colors
• 모든 Layer 색상의 색상 설정을 할 수 있다.
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



Schematic 메뉴
• Schematic Standard (열기/저장/미리보기/선택/이동/필터/계층도면/계층설정/프로브)

• Formatting (색상/폰트/크기/선두께/선모양/화살표 방향)

• Utilities (정렬/전원포트)

• Wiring (배선/버스/하네스/네트라벨/GND포트/VCC포트/시트심볼/포트/NO ERC/네트 색상)

• Navigation (파일 위치/이동/새로고침)

• Mixed Sim ( 시뮬레이션 설정 / 프로브선택)
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Active Bar

• Active Bar를 활용한 편한 설계 (Filter 기능을 활용한 객체 별 선택 가능)
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전기적 객체
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단축키

• 배선 Ctrl+W

• 컴포넌트 패널 P » P

• 검색 Ctrl + F

• 복사 Ctrl + C

• 붙여넣기 Ctrl + V

• 특수붙여넣기 Ctrl + Shift + V

• 네트 색상 오버레이 On/Off F5

• 선택 S » …

• 이동 M » …
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문서옵션

• Properties – General (Selection Filter / General / Page Options)
• 회로도 문서의 상세 설정
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문서옵션

• Properties – Parameters (Parameters / Rules)
• 회로도 문서 관리를 위한 파라미터 설정
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새로운 회로도 생성 시 기본 매개변수 목록
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특수문자 설명 특수문자 설명

=Address1 주소1 =DocumentNumber 문서번호

=Address2 주소2 =DrawnBy Drafter’s Name

=Address3 주소3 =Engineer 엔지니어

=Address4 주소4 =ImagePath 이미지경로

=ApprovedBy 승인자명 =Modified Date 최근 수정일

=Author 작성자명 =Organization 조직

=Checked By 검수자명 =Revision 개정

=CompanyName 회사명
=Rule

규칙 명령을 추가해서 사
용한 경우, 규칙 설명=CurrentDate 시스템 날짜

=CurrentTime 시스템 시간 =SheetNumber 시트번호

=Date 날짜(업데이트X) =SheetTotal 총 시트수

=DocumentFullPathAndNa
me

문서경로 및 이름 =Time 시간(업데이트X)

=DocumentName 문서이름 =Title 회로도 제목



회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



회로도 1/3
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회로도 2/3
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회로도 3/3
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부품목록
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Designator Comment Description

C10 C3216X5R1A476M160AB Chip Capacitor, 47 uF, +/- 20%, 10 V, -55 to 85 degC, 1206 (3216 Metric), RoHS, Tape and Reel

C11 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C12 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C13 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C14 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C15 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C18 C1005C0G1H220J050BA Chip Capacitor, 22 pF, +/- 5%, 50 V, -55 to 125 degC, 0402 (1005 Metric), RoHS, Tape and Reel

C19 C1005C0G1H220J050BA Chip Capacitor, 22 pF, +/- 5%, 50 V, -55 to 125 degC, 0402 (1005 Metric), RoHS, Tape and Reel

C25 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C37 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

C38 C2012X5R1C106K085AC Chip Capacitor, 10 uF, +/- 10%, 16 V, -55 to 85 degC, 0805 (2012 Metric), RoHS, Tape and Reel

C39 GRM033R60J104KE19D Chip Capacitor, 100 nF, +/- 10%, 6.3 V, -55 to 85 degC, 0201 (0603 Metric), RoHS, Tape and Reel

DS1 150060VS75000 WL-SMCW SMD Chip LED Top View Monocolor Waterclear, 30 mA, 2 V, -40 to 85 degC, 2-Pin SMD, RoHS, Tape and Reel

DS2 150060VS75000 WL-SMCW SMD Chip LED Top View Monocolor Waterclear, 30 mA, 2 V, -40 to 85 degC, 2-Pin SMD, RoHS, Tape and Reel

DS3 150060VS75000 WL-SMCW SMD Chip LED Top View Monocolor Waterclear, 30 mA, 2 V, -40 to 85 degC, 2-Pin SMD, RoHS, Tape and Reel

DS4 150060VS75000 WL-SMCW SMD Chip LED Top View Monocolor Waterclear, 30 mA, 2 V, -40 to 85 degC, 2-Pin SMD, RoHS, Tape and Reel

R10 ERJ-2GEJ241x Chip Resistor, 240 Ohm, +/- 5%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R11 ERJ-2RKF1002X Chip Resistor, 10 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R12 ERJ-2RKF1001X Chip Resistor, 1 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R13 ERJ-2RKF1001X Chip Resistor, 1 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R14 ERJ-2RKF1001X Chip Resistor, 1 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R15 ERJ-2RKF4701X Chip Resistor, 4.7 KOhm, +/- 1%, 0.1 W, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R30 ERJ-2RKF1001X Chip Resistor, 1 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

R9 ERJ-2RKF1002X Chip Resistor, 10 KOhm, +/- 1%, 100 mW, -55 to 155 degC, 0402 (1005 Metric), RoHS, Tape and Reel

U1 SPWF01SA Serial to WiFi Server IEEE802.11b/g/n Intelligent Module, 3.3 V, - 40 to 85 degC, 30-Pin SMD, RoHS, Tray

U2 STM32F103RBT7TR ARM Cortex-M3 32-bit MCU, 128 KB Flash, 20 KB Internal RAM, 51 I/Os, 64-pin LQFP, -40 to 105 degC, Tape and Reel

Y1 FQ5032B-24 Crystal Oscillator, SMD, 24MHz, Stab=30ppm 20.0pF



회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



프로젝트 파일 만들기

• File » New » Project… 선택
• Local Projects » Project Type : PCB <Defualt>선택

• Project Name : 프로젝트명

• Folder : 프로젝트 저장경로
• 설정한 경로에 프로젝트명과 동일한 이름의 폴더가 자

동 생성되고, 그 폴더 안에 프로젝트 생성된다.
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회로도 파일 만들기

• File » New » Schematic을 실행해서 Schematic을 파일을 추가한다.
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작업파일 저장

• File » Save [Ctrl+S] 저장
• 문서 변경사항 발생시 파일명 뒤에 *표시가 나타나고, 문서 저장 시 *표시가 사라진다.
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



템플릿 적용

• Design » Templates » General Templates » A3 (또는 A4 선택, Portrait는 세로가 긴 용지 형태)
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



부품 검색, 배치
1. 부품 검색

2. 부품 배치



부품 검색

• 부품 검색을 위해 컴포넌트 패널은 오른쪽 하단의 Panels » Components 또는 Place » Part… 실행한

다.

• 검색할 부품에 따라, 라이브러리파일을 선택하고 검색패널에 찾고자 하는 부품을 입력한다.
• R, L, C 등의 소자는 Miscellaneous Devices.IntLib

• 커넥터는 Miscellaneous Connect.IntLib
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부품 검색 : Components 패널
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Miscellaneous Device.IntLib (주요검색부품)

• 저항(Res)

• 인덕터(Inductor)

• 커패시터(Cap)

• 다이오드(Diode)

• LED(Led)

• 트랜스포머(Trans)

• 트랜지스터(Transistor)

• 컨버터 (ADC, DAC)

• 배터리(Battery)

• 7세그먼트(Dpy)

• 퓨즈(Fuse)

• JFET

• MOSFET

• 마이크(Mic)

• 모터(Motor)
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Miscellaneous Connectors.IntLib(주요검색부품)

• 케넥터(Connector)

• 헤더(Header)

• 소켓(PS2-6PIN)
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부품 검색 : Manufacturer Part Search

• Components 패널에서 ft232r 부품 검색 →

검색한 부품이 없는 경우 Maunfacturer

Part Serch를 통해 부품 검색

• Octopart와 CAD 모델 사용 시, Place 사용

가능
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USB Connectors (1734366-2 / TE Connectivity)

• Manufacture Part Search 
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rs485 (SN65HVD3082EDGKR / Texas Instruments)
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부품 검색, 배치
1. 부품 검색

2. 부품 배치



부품 속성

• 부품 배치 후, 부품을 더블 클릭하면 Properties(속성)창을 볼 수 있다. 설계참조번호(Designator)에는

R1을, 주석값(Comment)은 2.0k를 입력한다. 그리고, Parameters 옵션에서 Value값 보기를 비활성 시

킨다.
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회로심볼 핀번포/핀이름/핀위치 변경

• Component 선택 후 Properties 패널 - Pins섹션 선택

• Pin 잠금 해제 → 부품 핀 위치 변경 → Pin 잠금 설정
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



배선
1. 배선(배선/네트라벨/포트/전원심볼/오프시트커넥터)

2. 버스

3. 하네스



Wires [PW]

• Place » Wire [Ctrl+W]

• 배선 각도 전환 [Shift + Space]

• 90° 배선 / 45° 배선 / 모든 각도 / 자동 배선 모드
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배선 연결점 만들기

• AD18부터 배선연결점 오토 생성만 지원한다. 
• T분기 배선은 배선 교차지점에 오토정션 생성

• ╋분기 경우에는 ╋ 배선이 지나가는지 연결되는지 자동으로 알 수 없다. 그러므로, 먼저 T분기 모양 생성 후, 

나머지 배선을 연결해서 오토정션을 생성한다.
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Net Label [PN]

68

• 네트라벨은 배선에 네트명을 지정하고, 같은 시트내에서 물리적으로 떨어진 연결을 동일한 네트명으로 연결하여 회로를 간소

하게 표현한다.

• Place » Net Label

• 배선 위에 배치



Ports [PR]

• Properties 패널 – General » Properties 섹션
• Name : 포트명 입력

• I/O Type : 입출력 방향 설정
• Unspecified

• Output

• Input

• Bidirectional
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Off Sheet Connectors [PC]

70

• Place » Off Sheet Connector

• Properties패널 » Properties 섹

션
• Net Name : 네트명

• Style : Left / Right



배선
1. 배선(배선/네트라벨/포트/전원심볼/오프시트커넥터)

2. 버스

3. 하네스



버스 배선

• 버스는 여러 개의 네트를 결합하는데 사용하며, 어드레스 라인 또는 데이터 라인 연결 시 반복되는

동일한 작업을 간략하게 만들며 회로도를 보기 쉽게 만들어 주는 목적이다.
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버스 배선

• Place » Bus

• Place » Bus Entry
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버스 배선

• 각각의 네트는 네트라벨로 식별되며, 네트명은 <이름><식별번호1>, <이름><식별번호2>로 구성한다.
• (예, Address0, Address1, ..., Address n)

• 개별 네트가 결합하는 버스의 네트라벨은 <이름>[<시작 식별번호>..<종료 식별번호>]형식을 사용한다. 
• (예 : Address[7..0], LED[1..8])

-----------------------------------------------------------------------------------------------------------------

• 버스 네트라벨은 영문 사용을 권장한다. 만약, 버스 이름을 D2[0..7]로 지정하면, 컴파일시 네트명이 D20, 

D21..D27로 확장되어 네트명 충돌이 발생할 수 있다.
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배선
1. 배선(배선/네트라벨/포트/전원심볼/오프시트커넥터)

2. 버스

3. 하네스



하네스 커넥터

• 하네스 커넥터 (Harness Connector)
• 다양한 신호를 그룹화하여 버스 및 배선을 포함한 하네스 신호를 형성하는 컨테이너.

• Place » Harness  » Harness Connector
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하네스 분기

• 하네스 분기 (Harness Entry)
• 배선, 버스, 하네스 신호를 통해 신호가 결합되어 더 높은 수준의 신호 하네스를 형성하는 연결 지점

• Place » Harness  » Harness Entry
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하네스 신호

• 하네스 신호 (Signal Harness)
• 버스, 배선 및 기타 신호 장치를 포함한 다양한 신호를 논리적으로 그룹화하여 연결

• 하네스 신호는 PCB 프로젝트의 하위 회로 사이의 상위 레벨 추상 연결 생성 및 사용 가능

• 복잡한 설계를 단순화 하여, 설계 가독성 및 설계 재사용성을 높임

• Place » Harness  » Signal Harness
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



지시문 입력
1. 매개 변수 설정 / Blanket

2. 디퍼런셜 페어 매개 변수 설정

3. 컴파일 마스크



매개 변수 설정 / Blanket

• 매개 변수 설정 (Parameter Set)
• 회로도 단계에서 설계규칙 및 네트 클래스를 설정시 사용

• Place » Directives » Parameter Set 실행 후, 배선 위에 배치

• Blanket
• Parameter Set은 각각에 배선마다 연결해야 하지만, 회로도에서 특정 영역을 Blanket으로 설정 후 매개변수를

연결 할 수 있다.

• Place » Directives » Blanket 실행 후, 영역 설정.
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ERC 예외 지정

• ERC 예외 지정 (Generic No ERC) : 
• 프로젝트 컴파일시, 회로의 특정 지점에 의도적으로 오류 검사 검사를 제한하고, 나머지 회로에 대해 포괄적

인 검사 수행시 사용. 
• 예) 사용하지 않는 핀 끝점에 No ERC 마크 삽입

• Place » Directives » Generic No ERC
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디퍼런셜페어 매개 변수 설정

• Place » Directives » Differential Pair
• 해당 설정을 통해 Differential Pair 설정이 가능하며 Rule도 별도 지정 가능하다.
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컴파일 마스크

• 컴파일 마스크는 회로도에서 컴파일을 하지 않을 영역을 지정한다.

• Place » Directives » Compile Mask
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7.지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



Footprint 등록

• Tools » Footprint Manager…실행한다.

• 부품 목록에서 동일한 종류의 부품 선택 후, 오른쪽 창의 Add 버턴을 눌러서 Footprint를 추가한다.

• 모든 부품에 Footprint 설정하고, 오른쪽 하단의 변경확인(ECO 생성)버튼을 클릭한다.

• 그리고, 기술변경명령 창에서 검증->실행 버튼을 눌러서 Footprint 등록을 완료한다.
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7. 지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



회로도 설계 참조 번호 넣기

• Tool » Annotation » Annotate Schematics…
• Reset All » 변경 목록 갱신 » 변경 확인(ECO 생성)

• 변경 검증 » 변경 실행 » 닫기
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7.지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



프로젝트 옵션 설정
1. Error Reporting

2. Connection Matrix

3. Comparator

4. Options



Project Option : Error Reporting

• 컴파일을 통해 각 항목별 Error/Warning/No Report를 설정한다.

• Violation Associated with Nets에서 Nets with no driving source를 No Report(보고서 없음)으로

사용할 것을 권장한다.
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Project Option : Connection Matrix

• 회로 전체의 연결 상태를 체크하여, 부품들과 wire들이 정상적으로 연결되었는지 체크한다

92

• 치명적에러

• 에러

• 경고

• 보고서없음



Project Option : Comparator

• 프로젝트 옵션의 Comparator는 회로에서 PCB로 업데이트시, 회로와 PCB를 비교하여 데이터가 차이

점을 찾아서 업데이트할지, 아니면 차이점을 무시할지를 선택한다. 
• Changed Room Definitions       :       Ignore Differences

• Extra Component Classes :       Ignore Differences

• Extra Room Definitions :       Ignore Differences
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Project Option : Options

• 출력 옵션
• ▣ 각각의 출력 형식을 위한 분할 폴더 사용을 선택하면, Gerber, NC Drill, BOM 등 출력 형식별로 생성된 폴

더에 데이터가 출력된다.
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

1.지시문 입력

2. Footprint 등록

3. 설계 참조 번호 설정

4. 프로젝트 옵션 설정

5. 프로젝트 컴파일

6. 기타



프로젝트 컴파일

• Project » Compile PCB Project~.PrjPcb 를 실행해서 에러를 수정한다.
• 마우스 오른쪽 클릭 Compile Document.. System Message

• 에러가 발생되지 않으면, 메시지 창에는 Compile successful, no errors found 메시지가 표시된다.
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회로설계
1. Schematic GUI

2. 회로도 예제

3. 프로젝트 만들기

4. 템플릿 적용

5. 부품 검색, 배치

6. 배선 (Wire/Bus)

7.지시문 입력

8. Footprint 등록

9. 설계 참조 번호 설정

10. 프로젝트 옵션 설정

11. 프로젝트 컴파일

12. 기타



기타
1. 네트 색상 설정



네트 색상 설정

• View » Set Net Colors  » 색상 메뉴 선택 » 회로도에서 네트 색상을 설정하고 싶은 네트를 클릭한다

.
• Custom : 사용자 색 설정

• Clear Net Color : 네트 색상 지우기

• Clear All Net Colors : 모든 네트 색상 지우기

• [F5] : 네트 색상 보기 On/Off 모드 전환
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부품 검색

• Edit » Jump » Jump Component [단축키 J C] → 검색할 부품 설계 참조 번호 입력
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



PCB Editor UI
1. PCB 문서 만들기

2. 그리드/단위 설정

3. 레이어 보기 설정

4. PCB 패널



PCB 프로젝트 만들기

• 새로운 PCB 파일 만들기

• 프로젝트 선택 후 마우스 오른쪽 클릭 » Add New to Project » PCB 실행한다.

• 프로젝트에 *.PCB파일이 생성되면, 파일 선택 → 마우스 오른쪽 클릭 → 다른 이름으로 저장한

다.
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PCB Editor UI
1. PCB 문서 만들기

2. 그리드/단위 설정

3. 레이어 보기 설정

4. PCB 패널



단위 설정하기

• PCB 문서의 Properties 패널에서 Units 섹션에서 단위를 mm와 mils로 설정할 수 있다.
• PCB문서에서 mm<->mil 단위 전환 단축키 : Q

• 속성값 입력 시 임시로 mm<->mil 단위 전환 단축키 : Cltl+Q
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그리드 설정

• Properties » Grid Manager 섹션에서 임의의 그리드를 설정할 수 있다.

• Polar Grid

• Cartesian Grid
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격자 설정하기

• PCB 패널에서 G키를 누르면 Grid(격자)를 변경할 수 있다.

• 격자관리자는 아래 메뉴에서 실행하거나, [단축키 Ctrl + G]를 누르면 격자관리자를 실행할 수 있다.
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PCB Editor UI
1. PCB 문서 만들기

2. 그리드/단위 설정

3. 레이어 보기 설정

4. PCB 패널



View Configuration

• Panels » View Configuration   

[단축키 L]

• Layers & Colors • View Options
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레이어 정보
• Signal and Plane Layers → 각 층에 배치된 회로 정보로 패드와 패턴 정보를 포함하고 있다.

• TopLayer / BottomLayer : 외층

• Int1_power / Int2_gnd : 내층

• Component Layer Paris → 부품을 구성하는 레이어로, Top <->Bottom 레이어가 연결되어 있다.
• Top Overlay / Bottom Overlay : 부품의 외곽, 텍스트, 기타 보드 인식 정보이며, 전기적 속성은 없음. 

• Top Solder / Bottom Solder : 기판에 솔더레지스트를 도포하기 위해 필요한 정보. 

• Top Paste / Bottom Paste : SMD 부품을 자삽 처리할 경우, 패드위에 크림납을 도포하기 위해 필요한 메탈마스크를 제작하

기 위한 정보.

• Top Placement Outline / Bottom Placement Outline : Footprint 위에 실장되는 실제 부품 크기 정보

• Top 3D / Bottom 3D : 부품 3D 몸체 정보

• Mechanical Layers
• Board : 기판 보양

• Dimensions : 치수 표기

• Route Tool Path : 라우터 가공 패스 표기

• Other Layers
• DrillGuide → 드릴이 생성되는 위치에 드릴 가이드 표기

• KeepOutLayer → 금지영역 표기

• DrillDrawing → 보드에 포함된 Drill의 개수, 크기를 나타내는 정보

• MultiLayer → 시그널 레이어 전체 범주 표현
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기구레이어 – Dimension 레이어 추가

• 기구 레이어 추가
• Mechanical Layers 선택 → 마우스 오른쪽 클릭 →

Add Mechanical Layer 선택 기구 레이어를 추가 → Edit Layer 실행
• 레이어 이름 / 번호 / 타입 설정

• 1번 Board

• 4번 Dimensions
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보기 설정

• Panels » View Configuration » 

View Option

• 일반 설정
• 보기 환경 저장

• 3D OFF/ON
• 2D 보기 [단축키 2]

• 3D 보기 [단축키 3]

• Sigle Layer Mode
• 하나의 레이어만 보기 [Shift +S]

• Show Grid

• 객체 보기 설정
• Draft

• Transparency

• Mask and Dim Setting
• Dimmed Objects

• Highlighted Objects

• Masked Objects

• Additional Options

113



3D PCB 보기

• 2D 보기 (단축키 2) / 3D 보기 (단축키 3)

• 3D 보기 모드에서 보기 회전 : Shift + 마우스 오른쪽 버튼 클릭으로 회전
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적층구조 설정
1. Layer Stack Manager

1) 적층설정

2) 비아설정

3) 임피던스설정



레이어 스택 관리자 : 적층설정

• 레이어 스택 관리자는 적층구조, 각층 별 임피던스, Via타입을 설정한다.

• Design » Layer Stack Manager [단축키 D » K]를 실행한다.
• PCB적층 기본 구성은 2층 (2 x Signal, 0 x Plane)이다.

• PCB적층 구조를 4층 (4 x Signal, 0 x Plane)으로 변경하기 위해 Signal Layer 사이에서 마우스 오른쪽 버튼을

눌러서 Insert Layer above » Signal을 선택한다.
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레이어 스택 관리자 : 적층설정

• Altium에서 기본적으로 제공하는 레이어 스택업 사용하기
• Tools » Presets »

• 2 Layers (2 x Signal, 0 x Plane)

• 4 Layers (2 x Signal, 2 x Plane)

• 6 Layers (4 x Signal, 2 x Plane)

• 8 Layers (6 x Signal, 2 x Plane)

• 10 Layers (6 x Signal, 4 x Plane)

• 12 Layers (6 x Signal, 6 x Plane)

• 14 Layers (8 x Signal, 6 x Plane)

• 16 Layers (8 x Signal, 8 x Plane)
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레이어 스택 관리자 : 임피던스 설정

• 레이어 층 별로 임피던스 설정이 가능하다.
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레이어 스택 관리자 : 비아 타입 설정

• Drill Pairs : 드릴 쌍 관리자로 Through Hole Via, Blind Via, Buried Via 및 Drill Pair 설정
• Via Type

• First Layer : 드릴 시작 레이어

• Last Layer : 드릴 종료 레이어

• □uVia

• □Mirror

120

Through Hole Via

Buried Via

Blind Via



PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



PCB 기판 모양 정의
1. 기준점(0,0) 설정

2. 기판 외곽 설정 – 방법 1) 직접 그리기 (1/2)

3. 기판 외곽 설정 – 방법 2) DXF/DWG 파일 가져오기



기준점(0,0) 설정

• Edit » Orign » Set [단축키 E » O » S] 메뉴 실행

• 기준점 (0,0) 으로 설정하고 싶은 위치에 마우스 왼쪽 버튼 클릭
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기판 외곽 설정 – 방법 1) 직접 그리기 (1/2)

• 기판외곽선은 Keep-Out Layer에 생성한다.
• Place » Keepout » Track을 선택후 [tab] 키를 눌러서 Property로 이동한다. 

• Properties의 Line Width값 설정 후, Restricted for Layer를 “Keep-Out Layer”로 선택한다.

• Keepout Track 설정을 마친 후, 그리드에 맞춰 마우스 커서를 이동해서 기판 외곽선을 만든다.
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기판 외곽 설정 – 방법 1) 직접 그리기 (2/2)

• Edit » Jump » New Location 또는 [단축키 J » L] 을 이용하면 마우스 커서를 위치시키고 싶은 좌표

(X,Y)값으로 이동시킬 수 있다. 좌표값 입력 후 Enter 버튼을 두 번 입력해서, 선 위치를 고정시킨다. 
(이 기능은 마우스 커서를 원하는 좌표로 위치만 시키므로, 절대 마우스를 사용하지 말고 모든 값은 키보드로 입력

한다.)
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기판 외곽 설정 – 방법 2) DXF/DWG 파일 가져오기

• File » Import » DXF/DWG 실행 → 가져올 DXF/DWG 파일 선택 → 가져오기 설정
• 비율 : 밀리미터 / 밀 / 인치 / 기타 (1 AutoCAD 단위)

• Default Line Width : 선 두께 설정

• AutoCAD 좌표 (0,0) : AutoCAD의 (0,0) 위치를 Altium의 지정된 좌표로 이동시키기

• 레이어 맵핑 : 소스 레이어 이름(Auto CAD) <-> PCB 레이어 (Altium Designer 레이어)
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기판 영역 생성

• PCB Board Outline 객체 선택 → Design » Board Shape » Define from selected objects 실행
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기판 설정
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치수표기

• Place » Dimension » Linear 선택
• 치수 시작점 클릭

• [TAP키] 선택 후 Properties 설정
• Properties

• Layer : Dimensions

• Units
• Primary Units : Millimeters

• Value Precision : 소수점 아래 표기 허용 자릿수

• Value
• Format : 30.00mm (단위표기)

• 끝나는 점 클릭
• 가로/세로 방향 전환 : SpaceBar 입력
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부품 및 네트리스트를 PCB로 업데이트 하기
• PCB에 Footprint 및 네트리스트 정보 반영을 위해 아래 설정을 마쳐야 한다.

• 1. 프로젝트에 PCB 파일 생성 후 저장. (프로젝트에 PCB 파일이 미포함 되거나, 저장을 안하면 업데이트 불가)

• 2. PCB 적층구조 및 기판모양 설정

• Design » Update PCB Document WiFi.PcbDoc 메뉴 선택해서 기술 변경 명령 창을 띄운다.

• 회로도에 등록된 부품과 네트 정보를 PCB에 반영시키기 위해 변경 검증 » 변경 실행 버튼을 클릭한다.
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부품 및 네트리스트를 PCB로 업데이트 하기

• 기술 변경 명령 창에서 변경 실행을 마친 후 회로도에서 PCB로 부품 및 넷리스트 업데이트시 에러 발

생 유무를 확인하기 위해 ▣ 오류만 표시에 체크 후 이상이 없으면 PCB 작업을 시작한다.

• 아래 그림은 회로도에서 PCB로 부품 및 네트리스트를 올린 화면이다.
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부품 배치
1. 자동 배치

2. 수동 배치

3. 부품 회전 및 부품 실장 레이어 변경(Top<->Bottom)



부품 배치

• Tool » Component Placement
• Arrange Within Room

• Arrange Within Rectangle

• Arrange Outside Board

• Arrange Within Rectangle
• 선택한 영역 안에 부품 배치

• Component Placement 메뉴를 사용하면 손쉽게

영역별로 부품을 배치를 정렬할 수 있다.

• Arrange Outside Board
• 보드 아웃라인에 부품 배치
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부품 이동

• 부품 선택 후 드래그 앤 드롭으로 원하는 위치에 부품 배치

• Edit » Move » Component [단축키 M » C] 선택
• 마우스 왼쪽 버튼으로 부품 클릭 → 원하는 위치에 부푸 배치

• 빈 영역을 마우스 왼쪽 버튼으로 클릭 → 부품 선택 창 팝업 → 부품 선택 → 확인 → 원하는 위치에 부품 배

치
• 부품으로 이동 : 마우스 커서를 부품이 위치한 곳으로 이동시킴
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부품 회전

• 부품 회전
• 부품을 드래그 한 상태에서 [Spacebar]키를 누르면 를 회전이동모드(마우스로 부품 드래그, 또는 M » C로 부

품 선택) → SpaceBar를 누르면 반시계방향으로 90º씩 회전된다.

• 부품 이동모드(마우스로 부품 드래그, 또는 M » C로 부품 선택) → SpaceBar를 누르면 회전

• 부품 실장 위치 변경 Top<->Bottom 전환 : 부품 선택 후 [L]키 입력
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부품 배치
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부품 배치

• Top면 배치(Top View) • Bottom면 배치(Top View)
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패드

• Place » Pad
• Hole : 드릴로 가공될 구멍

• Land : 납이 뭍을 수 있는 영역
• Multi Layer : Through-hole타입 패드 제작

• Top / Bottom Layer : SMD타입 패드 제작

• Solder Mask

• Paste Mask
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패드

• 패드 속성

• 레이어 설정

• 홀 크기

• 랜드 크기

• Solder Mask

• Paste Mask
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PCB 설계 규칙 설정

• PCB 설계 규칙을 설정하기 위해 Design » Rules… 을 실행한다.

• Design Rule 설정 값을 위반하는 경우 위반사항에 대해서 메시지를 표시한다.

• Rule을 가지고 설계할 경우 설계에 대한 Error를 방지할 수가 있고 규칙적인 보드를 설계하는데 있어서 많은

도움이 된다.

• Design Rules
• Electrical

• Routing

• SMT

• Mask

• Plane

• Testpoint

• Manufactureing

• High Speed

• Placement

• Signal Integrity 143



클래스 만들기 (1/3)

• 객체를 클래스로 그룹화를 하면, 관리 및 규칙 설정을 쉽게 할 수 있다.
• Net Classes

• Component Classes

• Layer Classes

• Pad Classes

• From To Classes

• Differential Pair Classes

• Design Channel Classes

• Polygon Classes

• Structure Classes

• xSignal Classes
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클래스 만들기 (2/3)

• 신규 클래스 만들기
• Design » Classes… 메뉴 실행

• 객체 클래스 탐색기에서 Pad Classes 선택 → 마우스 오른쪽 버튼 클릭 → 클래스 추가
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클래스 만들기 (3/3)

• 클래스에 객체 추가
• 앞에서 생성한 Pad Classes – “Polygon” 객체 선택

• 비 요소 : 클래스에 포함되지 않은 객체

• 요소 : 클래스에 포함된 객체
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Design Rule 설정

• Design » Rules… 선택
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Design Rule 설정 : 이격 간격

• Design Rules – Electrical – Clearance
• Where The First Object Matches : All

• Where The First Object Matches : All

• Constraints : Different Nets Only / 0.2mm ( Hole~기타 객체 : 0)
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Design Rule 설정 : 이격간격

• Design Rules – Electrical – Clearance
• Where The First Object Matches : InAnyDifferentialPair

• Where The First Object Matches : InAnyDifferentialPair

• Constraints : Different Nets Only / 0.1mm
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Design Rule 설정 : 배선 두께

• Design Rules – Routing – Width
• Where The Object Matches : All

• Constraints : Min Width : 0.25mm / Preferred Width : 0.3mm / Max Width : 0.35mm
• Signal Net(일반 Digital net)의 경우 일반 샘플생산기준으로 Min : 0.1mm, Preferred : 0.15mm. Max : 0.2mm로 작업하

며, Routing Width의 경우 회로 설계사양 및 PCB제조 사양에 따라서 원하는 Size로 변경하여 사용
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Design Rule 설정 : 비아 크기

• Design Rules – Routing – Routing Via Style
• 비아 지름 크기 : 최소 0.5mm / 우선 0.6mm / 최대 0.7mm

• 비아 홀 크기 : 최소 0.25mm / 우선 0.3mm / 최대 0.35mm
• Via사양은 PCB제조 업체별로 변경될 수 있으며, 회로에 따라서 변경해서 사용한다. 그리고 아래 내용은 일반적인 사항의

Via이므로 그대로 사용하여 PCB제조시 PCB에 문제가 발생할 수 있으므로 반드시 제조사 및 각 회사의 특성에 맞도록 조

정

• -------------------
• Nomal Via

• Drill : 0.3Ø

• Land : 0.6Ø

• Power Via
• Drill : 0.7Ø

• Land : 1.2Ø

• Build-up Via
• Drill : 0.12Ø

• Land : 0.275Ø

• -------------------
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Design Rule 설정 : 디퍼런셜페어 설정

• Design Rules – Routing – Differential Pairs Routing
• Diff.Pairs 간격 선폭

• 최소 – 우선 – 최대 : 0.25mm

• Diff.Pairs 간격
• 최소 – 우선 – 최대 : 0.12mm

• Max Uncoupled Length : 1mm
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Design Rule 설정 : 폴리건 설정

• Design Rules – Plane – Polygon Connect Style
• PolygonConnect_All
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Design Rule 설정

• Design Rules – Plane – Polygon Connect Style

• 신규 규칙 만들기 : Polygon Connect Style 규칙 선택 → 마우스 오른쪽 버튼 클릭 → 새로운 규칙 생

성
• 규칙 이름 : PolygonConnect_Pad

• Where The First Object Matches : Custom Query → InPadClass(‘Polygon’)

• Where The Second Object Matches : All

• Constraints : Simple

• 기존 PolygonConnect_All

• PolygonConnect_Pad
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Design Rule 설정 : 테스트포인트

• Design Rules – Testpoint
• 일반적으로 TP포인트 사용시, 회로 및 PCB에 부품으로 생성해서 관리하는 경우가 많으므로 일반 PAD나 VIA

에서 TP포인트를 관리하지 않음. 그래서, 불필요한 에러검사를 줄이기 위해 아래 규칙은 모두 비활성으로 변

경

• □ Fabrication Testpoint Style

• □ Fabrication Testpoint Usage

• □ Assembly Testpoint Style

• □ Assembly Testpoint Usage
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라우팅
1. 라우팅 환경설정

2. Interactive Routing

3. Interactive Differential Pair Routing

4. Interactive Multi-Routing



마우스 커서 이동방향에 따른 객체 선택 방법

• 마우스 오른쪽 - 박스 안쪽 선택

• 마우스 왼쪽 - 모든 선택 객체
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라우팅 환경설정
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배선규칙

• 배선 길이는 짧게 하며, 레이어별 가로와 세로를 나눠서 배선한다.

• 배선각도는 직각 배선을 하지 않는다. 

• T분기 배선 금지하며, 배선 연결은 패드나 비아를 통해서 진행한다.

• 고속신호에서는 최대한 Via 사용을 줄인다.

• 아날로그 회로와 디지털 회로를 분리한다.

• GND는 가능한 Copper 로 만들며, 리턴패스를 고려해서 비아를 배치한다.
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배선

• 배선 관련 기능은 Route메뉴, 또는 ActiveBar에서

실행할 수 있습니다.

• 배선 도중 “~”버튼을 누르면 배선 관련 메뉴가 팝

업

됩니다.

161



대화형 라우팅

• 배선 중 Tap 키를 입력하면 Active하게 라우팅 옵션을 변경 할 수 있다.
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라우팅 중 Tap키
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Interactive Routing

• Route » Interactive Routing [Ctrl+W]

• Routing의 기본은 45°이지만 상황에 따라서 45°, 90°, 90°Arc, Soft Arc의 형태로 바꾸어서 Routing하는 경우

가 발생한다. 이 경우 Routing 진행시 각도 수정을 할 경우 [Shift+Space Bar]를 누른다.

• Top에서 Bottom으로 Layer를 변경시 [L] 버튼 클릭하면 레이어가 변경된다.
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배선 중 패턴 두께 변경

• 라우팅 중 [3] 키 누르면 선 폭 모드 User Choice/Rule Minimum/Rule Preferred/Rule Maximum 스위칭

• 라우팅 중 [Shift + W] 누르면 자주 사용하는 능동 배선 폭 리스트에서 원하는 값 선택
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배선 중 레이어 변경 및 비아 생성

• 라우팅 중, [*] 누르면 비아 생성 후 레이어 변경

• 라우팅 중, [2] 누르면 비아 생성 후 레이어 변경 없음

• 패드/비아에서 레이어 변경 시 [L] 선택, 오른쪽 숫자 키패드의 +,-로 레이어 이동
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능동 배선 단축키 (1/2)
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능동 배선 단축키 (2/2)
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Interactive Differential Pair Routing

• Route » Interactive Differential Pair Routing
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능동 차동 배선 단축키 (1/2)
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능동 차동 배선 단축키 (2/2)

170



멀티 배선

• Interactive Multi-Routing은 다수의 배선을 동시에 진행할 때 사용한다.

• Shift키를 눌러서 여러 개의 패드를 선택 후, Route » Interactive Multi-Routing를 실행한다.
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배선 완료
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



폴리건 만들기
1. Polygon 배치/수정/분할/잘라내기/병합

2. Polygon Manager



Polygon 배치

• Place » Polygon Pour…

• Place » Polygon Pour Cutout

• Place » Slice Polygon Pour
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Polygon 배치
• Polygon 배치

• Place » Polygon Pour… 실행

• 원하는 위치에 마우스로 클릭

• 다각형 편집 모드 변환 [Shift + Space]

• Any Angle

• Line 45/90

• Line 45/90 Width Arc (Radius: 2.54mm)

• 아크 감소:[,] 아크 증가 : [.]

• Line 90/90 Horizontal Start / Vertical Start

• Line 90/90 Horizontal Start With Arc (Radius: 

2.54mm)

• 아크 감소 : [,] 아크 증가 : [.]
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Polygon 수정
• Polygon 정점 이동

• Polygon 선택 → Ctrl을 누르고 정점 클릭 후 이동

• 다각형 편집 모드 변환 [Shift + Space]

• Mitering to segment

• Mitering to arc

• Mitering to vertex
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Polygon 분할

• Place » Slice Polygon Pour → Polygon을 분리를 위한 선 생성 → 마우스 오른쪽 버튼 클릭 → Split 

Confirm 창 팝업시 Yes 선택

• Tools  » Polygon Pours  » Repour All
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Polygon 잘라내기

• Place » Polygon Pour Cutout 실행 → Polygon을 잘라내고 싶은 영역 생성

• Tools  » Polygon Pours  » Repour All
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Polygon 병합

• 다수의 Polygon을 하나로 합치기
• 다수의 Polygon 선택 → 마우스 오른쪽 버튼 클릭 → Polygon Actions » Combine Selected Polygons 실행

• Tools  » Polygon Pours  » Repour All
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선택 영역 Polygon 빼기

• 선택 영역 Polygon 빼기
• 기본 Polygon (유지할 Polygon) 선택 후, 마우스 오른쪽 버튼 클릭 → Polygon Actions » Subtract Polygons 

From Selected 실행 → 제거할 Polygon에 마우스 왼쪽 버튼 클릭 → 마우스 오른쪽 버튼 클릭 →

• Polygon 다시 채움 실행
• Tools  » Polygon Pours  » Repour All

• 선택 → 명령 실행 → 기본 다각형에서 뺄 다각형 선택
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폴리건 만들기
1. Polygon 배치/수정/분할/잘라내기/병합

2. Polygon Manager



Polygon Pour Manager
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Polygon Pour Manager

• Tool » Polygon Pours » Polygon Manager [단축키 T » G » M]를 실행한다.

• Polygon Pour Manager에서 다각형 속성 변경, 푸어 순서 설정, 규칙 생성, 복사 및 삭제를 사용할

수 있다.

184



Polygon Pour Manager
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



비아스티칭/쉴딩/패드보강
1. 비아스티칭

2. 쉴딩

3. 패드보강



비아스티칭

• 비아스티칭
• GND Copper에서 원활한 전류 흐름과

열 감소를 위해 GND Copper 면적에

비아를 생성하기 위해 사용

• Tool » Via Stitching/Shielding » 
• Add Stitching to Net…

• Remove Via Stitching to Group…
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비아스티칭
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비아스티칭/쉴딩/패드보강
1. 비아스티칭

2. 쉴딩

3. 패드보강



쉴딩

• Tool » Via Stitching/Shielding » 
• Add Shielding to Net…

• Remove Via Shielding Group
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쉴딩
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비아스티칭/쉴딩/패드보강
1. 비아스티칭

2. 쉴딩

3. 패드보강



패드 보강
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패드보강

• Tool » Teardrops…
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



PCB 로고 만들기
1. PCB Logo Creator 스크립트 실행

2. PCB 로고 변환 옵션

3. PCB 로고 객체 결합

4. PCB 로고 크기 조절

5. 바코드 추가



PCB Logo Creator 스크립트 실행

• Script : PCB Logo Creator 다운로드 https://han.gl/djRMC
• 저장경로 : C:\Users\Public\Documents\Altium\AD19\Scripts (저장경로 변경 가능)

• File » Run Script… 를 눌러서 실행 아이템 선택 창 열기
• Browse… » From file… → 위 경로에 저장한 … PCB Logo Creator\PCBLogoCreator.PRJSCR 파일 선택

• 실행 스크립트 선택에서 Converter.PAS → 확인
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PCB 로고 변환 옵션

• PCB Logo 변환 옵션 설정 Load(이미지 선택) → Convert → Exit
• Board Layer : 로고를 삽입할 레이어 위치 선택(실크 : Top Overlay, Bottom Overlay)

• Scaling Factor : 이미지 원본 크기 그대로 삽입하는 경우, 1 (배치 후 크기 변경 가능)

• □ Negative : 음각 이미지 생성 □ ▣

• □ Mirror X : 좌우 반전

• □ Mirror Y : 상하 반전
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PCB 로고 객체 결합

• PCB Logo Creator 스크립트로 만든 로고는 다수의 선들로 구성되어 있다. 때문에, 이를 하나의 객체

로 선택

할 수 있도록 객체를 결합한다.

• 객체 선택 → 마우스 오른쪽 버튼 클릭 → Unions » Create Union from selected objects
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PCB 로고 크기 조절

• 로고 크기 조정은 로고를 구성하는 선 결합 → 로고선택 → 마우스 오른쪽 버튼 클릭 → Unions » 

Resize Union→ 객체 모서리 점 선택 → 확대 / 축소
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바코드 추가

• Place»String 명령
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정

3. PCB 기판 모양 정의

4. 회로 » PCB 업데이트

5. 부품배치

6. Design Rule / 클래스 설정

7. 라우팅

8. 폴리건 만들기

9. 비아스티칭/쉴딩/패드보강

10. 로고 만들기

11. DRC 검사

12. 기타



PCB 에러체크 (Design Rule Check)

• 설계 규칙 검사는 Tool » Design Rule Check 에서 실행한다. Rules To Check 화면에서 마우스 오

른쪽 버튼을 눌러서 “실시간&일괄 DRC – 사용한것 켬”을 선택하고, 왼쪽 하단 설계 규칙검사 실행

버튼을 눌러서 규칙 위배사항을 검사한다.
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DRC Report

• 설계 규칙 검사를 실행하면 Design Rule Verification Report와 Message 창을 확인할 수 있다.
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DRC 위배 표시

• DRC 위배사항을 화면에서 쉽게 식별하기 위해 환경설정에서 DRC 위배 표시 방식을 설정한다.

• Tool » Preferences [단축키 T » P]실행 후, PCB Editor-DRC Violation Display 환경설정 화면이동한다.

• DRC 위배 표시 방식 선택 화면에서 마우스 오른쪽 버튼을 눌러서 위배 세부사항&겹침 표시 – 사용

됨으로 선택한다.

• 실시간 DRC 에러가 난 지점에 마우스 커서를 올려두고 Shift + V를 누르면 위배사항을 확인할 수 있

다.
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PCB 설계
1. PCB Editor UI

2. 적층구조 설정
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기타
1. 네트 색상 지정하기

2. 유사객체찾기

3. 부품 글자위치 변경

4. PCB 기준 부품 설계참조번호 설정

5. 드릴 테이블

6. 레이어 스택 테이블

7. PCB 연 배열



네트 색상 지정하기

• PCB 패널에서 Nets를 선택 후, 지정할 네트를 더블클릭 한다.

• 네트 편집창에서 연결정보색상에 원하는 색상을 선택하고 확인을 눌러준다.

• 색상 설정을 마친 후 네트에 v 표시를 하면 네트 색상이 연걸 정보 색상에서 입력한 값으로 보인다.
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유사객체 찾기(1)
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유사객체 찾기(2)
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부품 글자 위치

• 부품 선택 » ActiveBar-Position Component Text »  부품 글자 위치 선택
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PCB 기준 부품 설계참조번호 설정

• PCB 설계도 기준으로 부품 설계참조번호 설정하기
• PCB 설계 완료 후, Tools » Re-Annotate… 실행한다. 

• 부품 설계참조번호 순서를 설정 후 확인버튼을 누른다.

• PCB 기준으로 회로도에 부품 설계참조번호 업데이트하기
• PCB 기준으로 변경된 부품 설계참조 번호를 회로도에 업데이트 하

기 위해, Design » Update Schematic in …*.PrjPcb 메뉴를 실행

한다. 

• 기술 변경 명령 창에서 변경 검증 → 변경 실행 후 닫기 버튼을 클

릭한다.
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드릴 테이블 (1/2)

• 드릴 테이블
• PCB 제조에 필요한 표준 요소.

• 보드에 사용된 각 드릴의 홀 크기 및 개수 표기

• 패드 및 비아와 같은 홀을 포함하는 개체 사용에 따라 드릴 테이블 실시간 업데이트

• Place » Drill Table
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드릴 테이블 (2/2)

• Place » Layer Stack Table
• Columns

• Symbol

• Count

• Hole Size

• Plated

• Hole Type

• Drill Layer Pair

• Via/Pad

• Pad Shape

• Template

• etc…

215



레이어 스택 테이블 (1/2)

• 레이어 스택 테이블
• PCB 설계에 구현된 레이어, 재료, 두께 및 유전 상수를 나타내는 표

• Place » Layer Stack Table
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레이어 스택 테이블 (2/2)

• Place » Layer Stack Table
• Properties

• □ Show Board Map

• ▣ Show Total Board Thickness

• Properties

• Layer

• Name

• Material

• Thickness

• Constant

• Gerber

• Board Layer Stack
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PCB 연 배열 (1/2)

• Place » Embedded Board Array/Panelize
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PCB 연 배열 (2/2)

• PCB Document

• Column Count

• Row Count
• Mirrored

• Link Location To Embedded Board Origin
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출력파일 생성
1. Output Job File 생성

2. Gerber 파일

3. NC Drill

4. 자삽파일

5. BOM



Output Job File 생성

• PCB 설계를 완료하면 Gerber Data, NC Drill Data, Pick &Place, Bill of Material 등의 출력물을 생성

해야 한다. 각각의 데이터를 개별적으로 출력할 수 있으며, Output Job File을 이용하면 필요한 데이

터를 일괄적으로 출력할 수 있다. 

• File » New » Output Job File 을 실행해서 아래 그림과 같이 Output Job File(*.OutJob) 파일을 생성

한다.
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Output Job File 생성

• 출력할 데이터 설정 후, 출력 컨테이너와 연결한다. 그리고 Tool » Run (F9) 를 실행하면 일괄적으로

데이터생성

할 수 있다.

• 출력 데이터
• Netlist Outputs

• Simulator Outputs

• Documentation Outputs

• PCB Prints

• Schematic Prints

• Assembly Outputs

• Generates pick and place file

• Fabrication Outputs

• Gerber Files

• NC Drill Files

• Report Outputs

• Bill of Materials

• Validation Outputs

• Export Outputs

• PostProceess Outputs
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출력파일 생성
1. Output Job File 생성

2. Gerber 파일

3. NC Drill

4. 자삽파일

5. BOM



Gerber 파일 만들기 (1/5)
• 거버 포맷(Gerber Format)이란 PCB의 구성요소(동박패턴, 솔더 마스크, 심볼, 마크등의 계층)와 드릴,라우터 등

의 외형 가공용 데이터를 표현한다.
• RS-274X(확장 거버, X거버) : 2D 도면으로 벡터 이미지를 표현하며, 현재 PCB 업계의 가장 일반화된 표준 형식

• RS-274X는 ASCII 형식 으로 내용이 구성되어 읽을 수 있고 각 명령과 좌표의 순서로 구성된다. 이미지의 기본적인 표현

방식은 주어진 좌표 영역에 라인(DRAW) 플래시 (FLASH), 그리고 주어진 영역을 채우는 방식(outline fill)으로 구성된다. 

또한 양화(Positive) / 음화(Negative) 형태로 그래픽 개체를 결합 할 수 있다.

• RS-274D (표준 거버) : 오래되고 불편하여 개발이 중지되었다. RS-274X에 대체되어 현재는 사용빈도가 적다.

• File » Fabrication Outputs » Gerber Files

• 거버 설정 - 일반
• 프로젝트 요구사항에 맞게 출력 파일에서 사용할 단위 및 형식을 지정한다.

• 4 : 2 형식은 0.01mm 해상도, 4 : 3은 0.001mm 해상도, 4 : 4 형식은 0.0001m 해상도다.

• 더 높은 해상도 중 하나를 사용하는 경우 PCB 제조업체에서 해당 형식을 지원하는지 확인해야 한다.
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Gerber 파일 만들기 (2/5)

• 거버 설정 - 레이어
• Layer To Plot

• 인쇄 레이어 - 사용 켬

• Mechanical Layers(s) to Add to All Plots

• ▣ 미 연결 중간 레이어 패드 포함
• Multi-Layer의 경우 Layer별로 Net가 연결 되지 않은

부분, Pad가 생성되지 않는 부분이 발생하여 PCB제조

작업 시 문제가 발생할 수 있으므로 상황에 따라 반드

시 “미 연결 중간 레이어 패드 포함＂을 체크하고 진행

한다.
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Gerber 파일 만들기 (3/5)

• 거버 설정 – 드릴 그림
• Drill Drawing Plots - ▣ Plot all used drill pairs

• Configure Drill Symbols… : 드릴 심볼 선택 (심볼 그림 / 크기별 문자 / 문자)

• Drill Guide Plots - ▣ Plot all used drill pairs
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Gerber 파일 만들기 (4/5)

• 거버 설정 – 고급
• 필름 크기

• ‘0’생략
• 생략하지 않음

• 앞쪽 생략 – Leading

• 뒤쪽 생략 - Trailing

• Position on Film
• 절대값 기준점 참고

• 상대값 기준점 참고

• 필름의 가운데
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Gerber 파일 만들기 (5/5)

• CAMtastic에서 거버파일 확인
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거버파일

• *.gtl Top Layer Gerber Data • *.gblBottom Layer Gerber Data 
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거버파일

• *.g1 Mid Layer 1 Gerber Data • *.g2 Mid Layer 2 Gerber Data
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거버파일

• *.gtsTop Solder Mask Gerber Data • *.gbs Bottom Solder Mask Gerber Data
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거버파일

• *.gtp Top Paste Mask Gerber Data • *.gbp Bottom Paste Mask Gerber Data
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거버파일

• *.gd1 Drill Symbol • *.ggd Drill Guide
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Gerber Data에 대한 확장자 설명

• *.G1, *G2, etc Mid-layer 1,2 etc.

• *.GBL Bottom Layer

• *.GBO Bottom Overlay

• *.GBP Bottom Paste Mask

• *.GBS Bottom Solder Mask

• *.GD1, GD2, etc. Drill Drawing

• *.GG1, GG2, etc. Drill Guide

• *.GKO Keep Out Layer

• *.GM1, GM2, etc.Mechanical Layer 1, 2, etc.

• *.GP1, GP2, etc.Internal Plane Layer 1, 2, etc.

• *.GPB Pad Master Bottom

• *.GPT Pad Master Top

• *.GTL Top Layer

• *.GTO Top Overlay

• *.GTP Top Paste Mask

• *.GTS Top Solder Mask

• *.P01, P02, etc. Gerber Panels

• *.APR Aperture File (generated when 

Embedded apertures (RS274X) on the Apertures 

tab is enabled)

• *.APT Aperture File (generated when 

Embedded apertures (RS274X) on the Apertures 

tab is not enabled)
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출력파일 생성
1. Output Job File 생성

2. Gerber 파일

3. NC Drill

4. 자삽파일

5. BOM



NC Drill 파일 만들기

• File » Fabrication Outputs » NC Drill Files

• NC 드릴 형식
• 단위 (인치/밀리미터)

• 형식 (4:2 / 4:3 / 4:4)

• ‘0’ 생략
• 생략하지 않음

• 앞쪽 생략 – Leading

• 뒤쪽 생략 – Trailing

• 좌표 위치
• 절대값 기준점 참고

• 상대값 기준점 참고

237



출력파일 생성
1. Output Job File 생성

2. Gerber 파일

3. NC Drill

4. 자삽파일

5. BOM



자삽 파일 만들기

• File » Assembly Outputs » Generates pick and place files
• Output Setting

• 단위 (인치/밀리미터)

• □Show Units
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출력파일 생성
1. Output Job File 생성

2. Gerber 파일

3. NC Drill

4. 자삽파일

5. BOM



BOM
1. BOM 엑셀 서식파일 제작

2. BOM 출력



엑셀 서식파일 만들기

242

• AD19 엑셀 서식파일 경로
• C:\Users\Public\Documents\Altium\AD19\Tem

plates

• 엑셀 서식 생성
• Files 표현

• Filed=FieldName
• Field=ProjectFileName 프로젝트 파일명

• Field=ReportDate BOM 레포트 생성일

• Columns 표현
• Column=ColumnName

• Column=Comment 부품 주석

• Column=Description 부품 설명

• Column=Designator 설계 참조번호

• Column=Quantity 부품 수량

• 그 외
• 엑셀 함수 사용 (ex. =SUM(E7:E20))



프로젝트 레벨, BOM 헤더 정보 매핑 (1/2)

• 프로젝트 레벨 정보는 일반적으로 Filed=Statement를 사용하여 BOM 문서의 헤더에 매핑된다.

• 이용 가능한 시스템 필드

• FIELD DESCRIPTION
• Currency 보고서 관리자 대화상자의 공급자 옵션 영역에서 선택한 currency

• DataSourceFileName BOM 데이터에 사용된 소스 파일 이름

• DataSourceFullPath BOM 데이터에 사용된 소스 전체 경로 + 파일 이름

• GeneratorDescription For a BOM, this field displays Bill of Materials.

• GeneratorName 보고서 관리자가 출력 생성시, BOM 생성자 이름

• OutputName 보고서 관리자에 표시되는 BOM 제목

( “BOM문서 [<DataSourceFileName>]"텍스트 제외).

• OutputType BOM의 경우 필드에는 BOM_PartType이 표시

• PCBDataSourceFileName PCB 데이터 소스파일 이름

• ProductionQuantity 보고서 관리자 대화상제에 정의된 생산 수량

• ProjectFileName PrjPcb 파일 이름 (파일 확장명 포함).

• ProjectFullPath 전체 경로 + 프로젝트 파일명
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프로젝트 레벨, BOM 헤더 정보 매핑 (2/2)

• FIELD DESCRIPTION
• ReportDate 보고서가 생성된 날짜

• ReportDateTime 보고서가 생성된 날짜 및 시간

• ReportTime 보고서가 생성된 시간

• TotalQuantity BOM 품목 수량 열의 합계

• Title BOM 보고서 대화상자 상단에 표시되는 제목

• VariantName Variant(파생) 관리자 대화상자에서 정의된 variant(파생) 이름

• VersionControl_RevNumber BOM문서의 현재 개정판

• VersionControl_ProjFolderRevNumber 프로젝트의 현재 개정판 (전체 프로젝트에 Commint 수행시 증

가).

• <UserProjectParameter_n> 사용자 정의 UserProjectParameter-n에 할당된 값을 표시
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문서 및 프로젝트 매개변수 매핑
• 시스템 필드는 물론, 회로도 문서 매개변수 ( 회로도 문서의 Properties 패널에 입력된 기본 및 사용자 정의 매개

변수 ) 및 프로젝트 매개변수 ( Project » Project Options… - Parameters )는 Fields 또는 Columns로 사용할 수

있다.
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• 동일한 매개변수가 문서 매개변수와 프로젝트 매개변수에 모두 존재하면, 프로젝트 매개변수가 우선된다. 동일한 문서 매개변수가 여러 문서에 있는 경우 계층
구조에서 상위 수준인 문서의 매개변수가 우선한다



BOM 품목 정보 매핑
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• 부품 매개변수
• Comment

• ComponentKind

• Description

• Designator

• DesignItemId

• Footprint

• LibRef

• LogicalDesignator

• PartType

• PhysicalPath

• Quantity

• UniqueIdName

• UniqueIdPath

• <UserParameter_n>

• PCB 부품 데이터
• enter-X(Mil)

• Center-Y(Mil)

• Center-X(mm)

• Center-Y(mm)

• Pad-X(Mil)

• Pad-Y(Mil)

• Pad-X(mm)

• Pad-Y(mm)

• Ref-X(Mil)

• Ref-Y(Mil)

• Ref-X(mm)

• Ref-Y(mm)

• Layer

• Rotation

• 공급자 데이터
• Manufacturer x

• Manufacturer Part Number x

• Supplier x

• Supplier Currency x

• Supplier Order Qty x

• Supplier Part Number x

• Supplier Stock x

• Supplier Subtotal x

• Supplier Unit Price x

• 사용자 정의 칼럼
• Colum=ColumName



엑셀BOM 서식파일 저장

• 엑셀 형식의 BOM 서식파일 저장은 반드시 아래 순서에 따라 진행한다.
• ① 파일 형식 : Excel 서식 파일 (*.xltx) 선택한다. 

• 서식 파일 저장경로가 자동으로 MS Office 서식파일 기본 경로(“C:\Users\PC\Documents\사용자 지정 Office 서식 파일

”)로 변경된다.

• ② 파일 저장경로 설정
• 서식파일은 Altium Designer 메뉴 사용시, 쉽게 템플릿 확인이 가능하도록, AD19 템플릿 기본 경로

(“C:\Users\Public\Documents\Altium\AD19\Templates”)에 저장하는 것을 권장한다.
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V



BOM
1. BOM 엑셀 서식파일 제작

2. BOM 출력



BOM 출력

• 회로도 또는 PCB 문서에서 Report » Bill of Materials을 실행 → 옵션 설정 후 Export… 클릭
• General 탭 - BOM 형식 및 템플릿을 설정

• Columns 탭 - 출력할 매개변수 값을 선택
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BOM에출력할 Columns 

항목 ON/OFF 설정

그룹설정은 Columns 아이템
선택후드래그를통해상단
항목으로이동시킨다.



BOM 아이템 목록 표기 모드 설정
• Flat view (평면보기) 

• 모든 부품에 대한 행을 표시

• Base view (기본 보기)
• 프로젝트의 각 고유 부품에 대한 행을 표시. Designator 열에는 이 유형의 모든 부품의 Designator가 나열된다.

• Consolidated view (통합 보기)
• 프로젝트에 Variant(조립 파생품)가 등록된 경우, 모든 Variant(조립 파생품) 정보를 통합 BOM에서 표시

250



BOM 출력 옵션

• File Format : BOM 형식 설정
• CSV (쉼표로 구분) (*.csv)

• Microsoft Excel Worksheet (*.xls, *.xlsx, *.xlt, *.xltx)

• Portable Document Format (*.pdf)

• Tab Delimited Text (*.txt)

• Web Page (*.htm, *.html)

• XML Spreadsheet (*.xml)

• Template : 서식 선택

• Add to Project : BOM 생성시, 프로젝트 추가하기

• Open Exported : BOM 파일 내보내기&저장 후 Excel에서 바로 열기

• Report BOM Violations in Messages : BOM 생성 중 Active BOM의 BOM 확인.
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라이브러리 제작 Gerber 파일

1. 회로심볼 만들기

2. Footprint 만들기

3. 패드/비아 라이브러리 만들기



회로심볼 만들기
1. 표준 부품 설계참조 번호

2. 회로 심볼 만들기



표준 부품 설계 참조 번호
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회로심볼 만들기
1. 표준 부품 설계참조 번호

2. 회로 심볼 만들기



회로심볼 만들기
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회로심볼 부품 속성값 입력
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Symbol Wizard를 이용하여 회로심볼 제작
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Symbol Wizard를 이용하여 회로심볼 제작

• 아래 그림처럼 정형화된 회로심볼을 만들기 위해서는 Tools → Symbol Wizard… 메뉴를 실행한다.
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Symbol Wizard

• Symbol Wizard를 사용해서 제작한 심볼이 만들어졌다.
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라이브러리 제작 Gerber 파일

1. 회로심볼 만들기

2. Footprint 만들기

3. 패드/비아 라이브러리 만들기



Footprint 만들기
1. Footprint 제작 규격

2. IPC Compliant Footprint Wizard…

3. Footprint Wizard… 

4. 수동으로 만들기
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칩부품 극성 CAP Diode / LED

SOIC, SOP, SSOP, etc QFP, TQFP BGA



Footprint 만들기
1. Footprint 제작 규격

2. IPC Compliant Footprint Wizard…

3. Footprint Wizard… 

4. 수동으로 만들기



IPC Compliant Footprint Wizard : STM-LQFP64_L (1/22)

• https://www.st.com/resource/en/datasheet/stm32f103tb.pdf
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https://www.st.com/resource/en/datasheet/stm32f103tb.pdf


IPC Compliant Footprint Wizard : STM-LQFP64_L (1/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (3/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (4/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (5/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (6/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (7/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (8/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (9/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (10/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (11/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (12/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (13/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (14/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (15/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (16/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (17/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (18/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (19/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (20/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (21/22)
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IPC Compliant Footprint Wizard : STM-LQFP64_L (22/22)
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Footprint 만들기
1. Footprint 제작 규격

2. IPC Compliant Footprint Wizard…

3. Footprint Wizard… 

4. 수동으로 만들기



PDIP-8 데이터시트

289



Footprint Wizard
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Footprint Wizard

• 홀 크기 : 0.9mm

• 랜드 크기 : 1.4mm

• 패드 가로 간격 : 7.62mm (300mil)

• 패드 세로 간격 : 2.54mm (100mil)
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Footprint Wizard

• 외곽 두께 : 0.2mm (Top Overlayer)

• 패드 수 : 8
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Footprint Wizard

• 부품 이름 : DIP8 입력 후, Footprint Wizard 종료.

• PCB Library 패널에서 부품 더블 클릭후, 부품 이름/설명/높이 설정.
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Footprint 만들기
1. Footprint 제작 규격

2. IPC Compliant Footprint Wizard…

3. Footprint Wizard… 

4. 수동으로 만들기



수동으로 만들기

• 패드 만들기
• Place » Pad

• Through Hole PAD / SMD PAD는 패드 속성에서 설

정
• 부품 몸체 표현

• 부품은 Top View 기준으로 제작

• 실크 정보를 표현하는 Overlay 레이어 사용
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실크선두께설정

Top View인경우 Top Overlay,

Bottom View인경우 Bottom Overlay 선택



패드 속성

• Through Hole PAD • SMD PAD
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Through Hole PAD 생성시, 

Multi-Layer 선택

SMD PAD 생성시,

Top Layer 선택

패드번호입력

레이어선택

홀크기입력

홀내벽도금유무선택



패드 속성
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랜드크기설정

Paste Mask 설정

Solder Mask 설정



수동으로 Footprint 만들기 : D1-MBRA160T3-D
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수동으로 Footprint 만들기 : D1-MBRA160T3-D
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라이브러리 제작 Gerber 파일

1. 회로심볼 만들기

2. Footprint 만들기

3. 패드/비아 라이브러리 만들기



패드/비아 라이브러리 만들기
1. 패드&비아 라이브러리 만들기

2. 패드&비아 라이브러리 등록하기

3. 패드&비아 라이브러리를 설계규칙에 적용하기



패드&비아 라이브러리 만들기

• 자주 사용하는 패드&비아의 크기/모양 설정 값을 라이브러리에 관리한다.
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File » New » Library » Pad Via 

Library 메뉴 실행 후 *.PVLib파일 생성



패드&비아 라이브러리에 패드&비아 추가하기

• *.PvLib 파일에서 Pad&Via를 생성하기 위해 Pad Via Library 패널을 실행한다.
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Panels » Pad Via Library

Metric(mm)/Imperial(mil) 

단위 선택



패드 템플릿 추가 및 설정
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Hole Size : 홀사이즈 설정

Tolerance : 공차 설정

Hole Type : Round/Square/Slot

Length : 패드 길이

Rotation : 회전각도

Plated : 홀 내벽 도금 체크

Pad 이름, 설명, 타입
(SMT/Through Hole) 설정

Paste Mask : 

메탈마스크 크기 설정

Solder Mask : 

메탈마스크 크기 설정

패드크기/모양설정

- Simple

- Top-Middle-Bottom

- Full Stack



비아 템플릿 추가 및 설정
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Hole 크기및
공차설정

Solder Mask : 

솔더레지스터 설정

SR 생성 방지시 Tented에 체크

Via 이름및
설명입력

비아크기/모양설정

- Simple

- Top-Middle-Bottom

- Full Stack



패드&비아 크기/모양/스택업 설정

• 패드&비아에 레이어 적층구조에 따라 층별 다른 크기 및 모양을 설정할 수 있다.
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패드/비아 라이브러리 만들기
1. 패드&비아 라이브러리 만들기

2. 패드&비아 라이브러리 등록하기

3. 패드&비아 라이브러리를 설계규칙에 적용하기



패드&비아 템플릿 등록하기
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Panels » PCB Pad Via Templates 실행

Intall.. 버튼 클릭후 사용할패드비아
라이브러리(*.PvLib)를 등록한다.

PCB Pad Via Templates

패널에서 등록된 패드 비아
템플릿 목록을 선택할 수 있
으며, 라이브러리 추가는 〮 
〮 〮 버튼을 클릭한다.



패드&비아 템플릿을 로컬 라이브러리로 등록하기
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템플릿에 등록된 패드/비아 목록에서
로컬환경서 사용할 패드/비아 선택

→ 마우스 오른쪽 버튼을 클릭→ Add 

To Internal Library 실행

로컬 패드/비아로 등록된 목록



패드/비아 라이브러리 만들기
1. 패드&비아 라이브러리 만들기

2. 패드&비아 라이브러리 등록하기

3. 패드&비아 라이브러리를 설계규칙에 적용하기



설계규칙에서 패드&비아 템플릿 적용하기
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Design » Rules…을 실행한다.

Design Rules » Routing » Routing Via Style에서

라우팅시 생성하는 비아 크기를 설정한다.

기본 조건은 All로 설정되어 있는데, 특정 네트 및 기타 조건별로
비아 크기를 설정할 수 있다.

비아/패드 템플릿에 적용된

Min/Max preferred → Template 

preferred로 변경한다.



설계규칙에서 단일 비아를 등록한 경우

• Design Rule에서 단일 비아 선택 후, 라우팅시 [*]를 누르면 선택한 비아를 만든다.
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설계규칙에서 다수의 비아를 등록한 경우

• Design Rule에서 여러 개의 비아의 Enable 항목을 선택하면, 라우팅시 [Shift+V]를 누르면, 아래 그림

과 같이 Choose Via Sizes 창에서 확인된 비아 목록에서 사용할 비아를 선택한다.
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